How to install xLink For SOCOM 2 Mac OS X Guide

Discussion in 'SOCOM On XLink For The PS2' started by Modios, Jan 10, 2017.

  1. Modios

    Modios .:fLaSh:.



    Edit: (this was actually a reply to another thread, but it looks like it was made into its own op)

    @WAR_PIG was having issues trying to get Kai running on a mac, so I'm trying to install the mac version now so I can better understand where exactly he is running into the issue..


    My Mac mini is connected to the internet via wifi,
    my PS2 is connected directly to my Mac via ethernet cable.
    (They say it's best to avoid using wifi if possible, but I have never had an issue with it)



    I downloaded the latest Kai release for intel based macs from here: https://www.teamxlink.co.uk/downloads.php

    Then, I installed it on OSX just like you would install any other application.
    (make sure you let it through your firewall)


    If you get the "cannot be installed, unknown/untrusted app" warning:

    Click the apple in the top left of the screen;
    Select 'system preferences' and go to security. It should give you the option to allow whatever app you just tried to run.
    (you might need to click the little lock & enter your password before it will allow you to run it)


    From there, I just followed the steps in the other setup op: http://community.therealsocom.com/t...link-for-socom-2-guide-updated-1-3-2013.3571/


    & used this video to fill in the blanks:




    The latest release makes the process much easier. I didn't need any additional applications for the UI, and I didn't need to touch my terminal to install/run anything at all.

    I didn't run into any issues, but I can always do a fresh install and attempt to recreate any issues you might be having to see if I can find a fix. I'm not really all that familiar with OS X but I'll help where I can
     
    Last edited: Jan 13, 2017
    Tawok and SkiMask like this.
  2. Animal-_-

    Animal-_- TRS Staff

    From the general other Xlink setup thread...
     
  3. oni64

    oni64 Third Person illusionist

    I think Toronto orb might is dead nowadays. There is only like 2 orbs now.
     
  4. Laziness

    Laziness Free Pizza

    Yea I haven't really played since they went down to two orbs. What ever the orbs are you just put it in all caps at the end.
     
  5. SkiMask

    SkiMask Devil's Advocate

    . Spot reserved for two orb command line paste.

    cd /Applications/XLink\ Kai.app/Contents; ./MacOS/kaiengine --Team_XLink_HQ

    (Not sure team X looks like this?) I will retrieve Capital once it gets put back up as I see they are on single orb again.

    So clarifying question, did you use "Kaid" to do the initial setup and then it installs Kai too?
     
  6. Modios

    Modios .:fLaSh:.

    I have no idea what Kaid is..?

    I downloaded the latest Kai for intel based macs, installed it and ran it like any other application.

    I didn't need to touch my terminal at all to install or run it, and got online without issue
     
  7. Changing orbitals through terminal is no longer needed with XLink Kai version 7.4.29, or greater. You just click the XLink icon to change orbitals.
     
    Modios likes this.
  8. SkiMask

    SkiMask Devil's Advocate

    Maybe we update the page with that link then? I think it would help. Maybe same with making a fresh vid all nice and quick with some FAQS...
     
    Modios likes this.
  9. Modios

    Modios .:fLaSh:.

    I'll make a walkthrough video of exactly what I did (from scratch) once I have the time & update the op wth it, I'll be sure to include that detail when I do.

    Honestly, most of the questions posted on that guys video, he basically answered in the video.There were just a few that were no longer relevant with the latest release
     
    Last edited: Jan 11, 2017
  10. SkiMask

    SkiMask Devil's Advocate

    Sweet! That would be most helpful and them common questions are a good thing to type out in the comments. You'll get people having them quick and wanting a fast answer. Maybe link to spot in video or something? or whatever. Thanks!
     
  11. EmericAn

    EmericAn Green Up

    So I just notice my Macbook does not have an ethernet slot... Can my PS2 run into the router? Or does it have to run into a computer?
     
  12. Modios

    Modios .:fLaSh:.

    I run mine into my pc, but you can also run it through your router. I think that's how most of these guys do it.

    You'll just need an Ethernet cord long enough to reach your tv/ps2
     
    EmericAn likes this.
  13. EmericAn

    EmericAn Green Up

    Awesome, thanks for the quick reply.
     
  14. Modios

    Modios .:fLaSh:.

    No prob man.

    Hope to see you on soon!
     
  15. EmericAn

    EmericAn Green Up

    I am running into some issues here. Is there anyone that could help me via pm step by step.
     
  16. MACK IS GOD

    MACK IS GOD VP of Toxicity

    Hang in there. Im sure as soon as someone with the know how sees this they'll be happy to assist. Dont get discouraged if you dont get a response right away, someone will definitely be able to give you a hand at some point soon.

    I wish I could help but Im about as computer literate as a mentally challenged caveman.
     
    EmericAn likes this.
  17. Modios

    Modios .:fLaSh:.

    Since I bypassed my router altogether, I don't really know how to help him get it running through his router (I did it the easy way)


    Would somebody with a hardline be able to help this guy get setup?
    He says he can see the other players' ping in the lobby, but can't see any games
     
    Last edited: Jan 18, 2017
    EmericAn likes this.
  18. EmericAn

    EmericAn Green Up

    Yes this is all I am stuck on. Ill try in the chat on there and see if anyone knows.
     
  19. MACK IS GOD

    MACK IS GOD VP of Toxicity

    Were you able to get help finding a solution?

    Usually @Dominator94 is able to help with the Xlink stuff but I havent seen him on here in a couple days. Hes one of the most knowledgeable guys around for that sort of stuff so if you still are having an issue Im sure he will be able to help when he checks in again.
     
  20. SkiMask

    SkiMask Devil's Advocate

    Worst case scenario and you get tired of waiting, I would just head to the source for your troubleshooting needs.

    https://www.teamxlink.co.uk/forum/

    Good luck and do let us know how it goes.
     

Share This Page