How to install xLink For SOCOM 2 Mac OS X Guide

Discussion in 'SOCOM On XLink' started by Modios, Jan 10, 2017.

  1. Laziness

    Laziness Free Pizza

    whats happening?
     
  2. Skyline

    Skyline 203 Spammer

    So I use the thunderbolt to Ethernet adapter for my MAC. Nothing is working with the EN's. Sometimes it flat out doesn't work, other times it says communication lost between UI and Engine. I tried the utun option as I only have two thunderbolts and that was the only one that matched up with two options.

    Really don't know what I could be doing wrong. Did exactly what I was supposed to according to the video.
     
  3. MR.BLONDE

    MR.BLONDE HE STINKS AND I DON'T LIKE HIM

    Take my advice with a grain of salt, but I find that UI/Engine difficulties don't correlate with Ethernet cables. Are you using a setup where your computer is wired into your modem/router/whathaveyou?
     
  4. Skyline

    Skyline 203 Spammer

    No, mine is connected wirelessly.
     
  5. MR.BLONDE

    MR.BLONDE HE STINKS AND I DON'T LIKE HIM

    I see. Well, anecdotally, I found that every time I got that specific error message, it was due to me closing my laptop and sending it to sleep mode, or the engine automatically kicking me off for perceived inactivity. I'm sure the former isn't your issue, so I think you may want to head into your configurations on xLink and make sure Disable Sleep Mode is checked off.

    EDIT: Also, the Close Engine After setting may have somehow been erroneously checked off. Make sure that is set to Never.
     
  6. Skyline

    Skyline 203 Spammer

    All of that looks like it's how it should be. I even did a hardwire from the mac to the router, and nothing for a few minutes. Then it found ONE game, even though they are apparently two or three lobbies up according to a friend of mine playing.

    I can't join the current one I see due to multiplayer error.
     
  7. MR.BLONDE

    MR.BLONDE HE STINKS AND I DON'T LIKE HIM

    I'm just going to run down some common troubleshooting steps that I use, and that generally solve my problems when they spring up.

    -Check the Metrics tab on the top. Reachable should read yes, and it should find your console. Also, if you keep clicking the metrics tab, you'll refresh it. Keep an eye on the Traffic counters while doing so.

    -You may want to check your router settings on your computer to make sure you haven't forwarded any ports to different computers or game consoles that may be interfering with xLink.

    -I'm sure you've tried this by now, but make sure to cycle through all available orbitals and Refresh List frequently on the PS2 itself.

    I'll post more as I think of them, but I'll try to omit any that could involve significant changes that will be hard to restore.
     
  8. Skyline

    Skyline 203 Spammer

    Reachable and it finds the system. I did some port forwarding just now just in case the UDNP was having an issue, still the same stuff.
     
  9. MR.BLONDE

    MR.BLONDE HE STINKS AND I DON'T LIKE HIM

    That's about all I can muster, I would continue to consult the MAC setup guides and asl om the xLink forums.
     
  10. Skyline

    Skyline 203 Spammer

    So I actually got it to work. I used to be into computers, but eventually got more into photography. With that said I noticed the "local port" was higher than the 30,000 port that's supposed to be used. Perhaps I did something wrong somewhere, or my new router just changes things, so I set the number higher than the one it said.

    Updated, rebooted everything, and while the local port number changed again, it wasn't higher than the one I had set (maybe I will need to set it to the max of 64,500 or whatever it is. Not sure about security though). Well that did it. I could see everyone's pings, the rooms appeared immediately and I didn't have an issue joining.

    Hoping this is it and I'm done. Not that I just happened to get lucky.
     
    MR.BLONDE likes this.
  11. MR.BLONDE

    MR.BLONDE HE STINKS AND I DON'T LIKE HIM

    Ah, yes. The local port will be randomly selected if it isn't specified to one specific port, so what may have been happening was it was either randomly selecting ports that were out of your network's range of ports, or selecting a port that has already been forwarded to something else. If random port selection works, I would keep it that way for now.
     
  12. Lord Swagger

    Lord Swagger Green Up

    does anyone have knowledge about running PSCX2 on a Mac to be able to play?
     
  13. =Ronin=

    =Ronin= The Captain of Makin' it Happen

Share This Page