Setting up PCSX2 to work with Xlink Kai

Discussion in 'SOCOM On XLink' started by 1UP, Aug 8, 2017.

  1. 1UP

    1UP The BETTER Socom on PC Guy

    Unless windows detects that as a headset I couldn't tell you how to get that to work.
     
  2. Harry62

    Harry62 hacker

    Check out this guide. Looks like there may be an update for the controller or something that allows headsets to work with windows. Requires windows 10.
    https://support.xbox.com/en-US/xbox-on-windows/accessories/stereo-headset-adapter-windows-10
     
    1UP likes this.
  3. Animal-_-

    Animal-_- TRS Staff

    @1UP Seeing as neither Brad's or your guides are truly the "official" TRS guides for this I would appreciate it if you changed the title of this thread back to what it was before. It's not helpful for you two to take your disagreements beyond strict technical criticisms when there are members who are new to using the emulator and might need help getting set up without getting caught up in a personal argument.
     
  4. 1UP

    1UP The BETTER Socom on PC Guy

    There's no such thing. If anything though it was a jab since no one here seems to be really grasping what he is doing.

    It's not really helpful when you allow someone to blatantly post cheats but hey what do I know.
     
  5. 1UP

    1UP The BETTER Socom on PC Guy

    The guide was updated to include step by step instructions on installing the HDD maps. This was something that was supposed to be in originally but due to the maps running terrible I never included it. However due to the findings dealing with running the game in D3D 9 software mode, most of the problems were solved with that.
     
  6. dizee

    dizee Lucille is thirsty

    Last Bastion and After Hours run great and look amazing.
    Liberation runs about as well as Crossroads does. Good thing its the worst HDD map.
     
  7. Socom_JbuCk

    Socom_JbuCk skOPe

    Thanks for the guide! It was really simple to follow. The only issue I had was setting up my ps3 controller. I ended up just using an Xbox one controller instead and it worked great (even though I much prefer the ds3).
     
  8. ShellShock-_-

    ShellShock-_- Green Up

    Hey guys, I've been a peeping tom on this page for years now. I've been playing H-Hour to get the Socom feels back, and I saw that the members here at TRS have found a way to use an emulator to play on PC. I just bought a DS3 controller, and I have used @1UP 's tutorial. Thanks a lot man!

    So, I got all the way to the "Playing SOCOM 2" step. I am a bit confused. I do not have a SOCOM 2 disc currently. Do I actually need one, or is there already an ISO that I can download/use so I can play ?

    If I do need the disc, no worries, I will just purchase one on amazon and just wait the few days it takes for me to receive it. I just need guidance in this aspect in order to proceed.

    Thanks again.

    PS. I see some players on XLINK that I played SOCOM 4 with (I know, that game sucked). @MADDENKING1980 @TOMBSTONE4U , and a few others... I believe I was in wC (wrecking Crew) with you guys. I totally forget my PS3 ID, but I remember your names for sure.

    *** EDIT *** : OK, so someone was nice enough to help me in the xlink lobby and reffered me to an iso download. However, I am not launching the game and getting stuck on this screen:

    [​IMG]

    I click X, and nothing works. I can confirm that I set up the DS3 per the tutorial, and if I hit my PS button on the control, it will bring up a recording device, and I can use the sticks/buttons to navigate through. So, I am assuming that it is working properly.

    Any thoughts or help would be great. Thanks.
     
    Last edited: Sep 10, 2017
  9. Swill

    Swill Ninja SEAL

    You DO NOT need a disk, you just need the proper ISO downloaded. I think @1UP or @dizee can send you the link for it.
     
  10. dizee

    dizee Lucille is thirsty

  11. ShellShock-_-

    ShellShock-_- Green Up

    I am using the iso that you sent me. Thank you!

    Still running into an issue though. I also downloaded that Socom on PC, and utilized their Memory Card because the one that was in @1UP 's tutorial, just wouldn't work. I followed it to the T and it keeps saying that no data is on the memory card. So using Brad's memory card, I got past the screen shot error above.

    I now get a message saying that the HDD is not installed. Click X to continue.

    I still cannot click X. I can use the sticks and buttons for other programs. But not in the emulator itself.
     
  12. 1UP

    1UP The BETTER Socom on PC Guy

    It's because there isn't any Socom related data on the card. The only data that would ever be present is if you were playing single player or saved your settings. The only data that exists is the net config file. It's not an error, that's just what happens when you launch the game for the first time without having a save. That is working as intended.

    The reason you are having that problem with the HDD is because you are using a save that had that setting saved. Again it's not an issue, you can either turn it off in settings or ignore it.

    As for the controller, without seeing what your controller settings look like, I can't tell if it is setup correctly. There are 2 screens:
    [​IMG]

    And
    [​IMG]

    If it says Disconnected in either one of those then your controller isn't working.
     
    Harry62 likes this.
  13. Harry62

    Harry62 hacker

    Try this:

    1: Start pcsx2.
    2. Click Config >> Plugins/BIOS Selector.

    When you do this watch the PCSX2 log(white window beside the main pcsx2 blue window) for any "red text" errors. PCSX2 will load each of the plugins and should display any issue found when opening the plugins panel. Do you see any errors in the log window?
     
  14. ShellShock-_-

    ShellShock-_- Green Up

    Thanks for the continuous help.

    @1UP , here is what my controller screen looks like:

    General Tab:
    [​IMG]

    Pad 1 tab:
    [​IMG]


    There are a few discrepancies between mine and yours:

    1. Under General tab, it will not allow me to select "DualSHock 3 Native Mode" and under "Device Diagnostics", my DS3 is not showing up.

    2. Under the Pad 1 Tab, under "Add Force Feedback Effect", I only have the option of "XInput Pad 0" and not the DS3 controller.
     
  15. ShellShock-_-

    ShellShock-_- Green Up

    OK, compeletly disregard from now 'gents.

    I was following @Harry62 directions and looked under my Plugins/BIOS selector options, and everything is completely not saved.....

    Let me redo 1UP's tutorial and I'll get back to you guys. Sorry for wasting your time at this point.
     
  16. 1UP

    1UP The BETTER Socom on PC Guy

    I wouldn't worry about it, that's why this thread exists is to help people who might be having problems getting it setup.
     
  17. ShellShock-_-

    ShellShock-_- Green Up

    Awesome. I got it all up and running now. I just cannot see the rooms in the LAN. On Xlink, it shows that there are 2 rooms currently up: .hexium 4/16 players and TommyTangerine 12/16 players.

    Any suggestions?
     
  18. 1UP

    1UP The BETTER Socom on PC Guy

    Xlink doesn't show the actual in game rooms. The rooms you are seeing are like private XLINK channels. If you are not able to see rooms on the ps2 side of things make sure that xlink is using the TAP adapter.
    https://1upsdevelopment.com/pcsx2-socom-2-xlink/#settingupxlinkkai

    also make sure the network plugin is setup correctly:
    I would suggest taking a look at the troubleshooting section for the network plugin:
    https://1upsdevelopment.com/pcsx2-socom-2-xlink/#troubleshooting

    If both of those look correct for you, then it could be an issue with windows firewall or if you anti virus has one. You will have to make an exception for pcsx2 to pass through.

    I'll be adding instructions for how to make an exception for the windows firewall sometime soon.
     
  19. ShellShock-_-

    ShellShock-_- Green Up

    I appreciate all the help that you're giving me. I went back through and troubleshooted everything + allowed pcsx2 through my firewall and still no dice. I'll keep looking into it tonight as well.
     

Share This Page