XLINK Guide Updated for 2017

Discussion in 'SOCOM On XLink' started by Tawok, Feb 11, 2017.

  1. Skyline

    Skyline 203 Spammer

    Okay guys, having an issue.

    Every time I try to join a room I get an error about "experiencing a multiplayer error, please try a different game." In the beginning there were two rooms up to my knowledge. The one has always been showing, while the other one didn't for about 5-10min, but eventually it showed too. No matter the amount of refreshing it wouldn't let me join them.

    Now I am using an older Windows Laptop that needless to say was abused by my girlfriend, so there is a possibility it's just jacked. I'm going to get the Ethernet adapter for my Macbook tomorrow, and still plan on doing it regardless of if I just did something wrong in general.

    I have two connections setup. One being fully automatic, the other one having the custom IP. Both are setup with hardwire (PS2 to Router, Laptop to Router).

    Anyone ever had this issue? Know a fix?

    UPDATE: Found another room show up randomly, and I could join. For some reason I want to say this could be a NAT issue? Or possibly one? Is that an issue on Xlink? I recall Shimmy and I have that issue on PS4 with certain things, and he was the host of the one room. Possibility?

    UPDATE 2: I managed to get in with the TRS guys, but still nothing from Shimmy.
     
    Last edited: Mar 4, 2017
  2. Advent

    Advent Green Up

    Yes. Twice.. no effect.
     
  3. Advent

    Advent Green Up

    Yes.. i did but it didn t help.
     
  4. Advent

    Advent Green Up

    Hello Guys, now I can log in.. But im using wifi on my laptop and cable in the playstation. I see everyones PING in the xlinklobby but I see no rooms in the socom lobby
     
  5. MR.BLONDE

    MR.BLONDE HE STINKS AND I DON'T LIKE HIM

    It may be easier for us yo troubleshoot your issues if we can speak directly. Do you have Discord installed on your computer?
     
  6. dizee

    dizee Lucille is thirsty

    I am trying to help him remotely but everything is in dutch which is making it 100x harder.

    I bridged his connection but no rooms are showing up for him. I think its a router issue.
     
  7. Skyline

    Skyline 203 Spammer

    The rooms don't show up for me either still, but last night, after like 5-10min of waiting, they eventually started to appear.
     
  8. dizee

    dizee Lucille is thirsty

    The only things I can think of are if you use a Linksys router like I do, login to it and:

    1) Enable UPnP
    2) Set the PC running xlink as your DMZ

    i did these after I had issues with MP join failures and it fixed them.
     
  9. Skyline

    Skyline 203 Spammer

    I don't have a linksys, but I'm willing to give this a try. How exactly do I make it the DMZ? Is that done through the router as well?
     
  10. Skyline

    Skyline 203 Spammer

    Actually figured it out, but still nothing. Just the same room it's only been showing. Honestly wondering if this is a NAT issue. Could it be? Or does XLink just have issues every no and then?
     
  11. Tawok

    Tawok Not *That* Kinda Guy

    XLINK can definitely be temperamental. Have you been able to join a working room since you started your journey?
     
  12. dizee

    dizee Lucille is thirsty



    to find out your PC's IP (the pc running xlink) on your router, go to control panel>network & internet>network &sharing center then click local area connection, hit details. ipv4 address is what you need to set as your DMZ
     
    Last edited: Mar 4, 2017
  13. Skyline

    Skyline 203 Spammer

    It has, in a sense. I only got everything setup yesterday, but so far have only been able to join two rooms out of possibly 5 or six that have been made.
     
  14. Advent

    Advent Green Up

    Hello Guys,

    Thank you for your help all.. Its working now. I had another question my brother who lives in the same home as me wants to play aswell. We have 1 ip dress at home and 1 router.. In my room I use router >> Cable >> laptop and Router >> Cable >> PS2.. I was wondering if Its possible to use wifi and bridge connection and then Laptop >> Cable >> PS2.
    Is there anyone here who can help me out please?

    Thanks again all!

    Advent
     
    dizee likes this.
  15. dizee

    dizee Lucille is thirsty

    Glad it is working, what fixed it?

    As far as 2 playing in the same house, I dont have a clue but I did find this on the xlink forums

    https://www.teamxlink.co.uk/forum/viewtopic.php?t=44390&sid=a70c48bd4c02c99f3676ccaae507ae6a
     
  16. Skyline

    Skyline 203 Spammer

    Alright I'm just gonna say I'm an idiot. Can someone help me on Skype with setting this damn thing up? Seems like I'm one of the few people with not seeing rooms and what not. Desperate here lol.
     
  17. Johnson30

    Johnson30 Green Up

    I have done everything that you have displayed here. In metrics it lists my PS2... When I go into LAN briefing room, there are never any rooms up.

    I have done all the firewall settings.
     
  18. Tawok

    Tawok Not *That* Kinda Guy

    The first thing to check if your metrics list your PS2, is to ask the lobby - Is there a game up? There's a chance that everyone is waiting to see the lobby instead of taking the initiative. Sounds ridiculous, but I've seen it plenty of times.

    So long as your firewall is bypassing the port you set in your XLINK config, and your metrics list your PS2, you should be golden. Sometimes you just need to reset your PS2 a few times (I know, it's brutal, bear with me) to hit the sweet spot on the connection. SOCRACK is worth it.
     
    MR.BLONDE likes this.
  19. SkiMask

    SkiMask Devil's Advocate

    Otherwise we CAN go deeper if need be.

    I always fire up Kai first and have that all ready to go. I log in, and when I hit the arena splash page, I usually see at least a few dozen sitting there. Usually a orange highlighted name too. Then I go to the lower right hand corner of my laptop's desktop and click the little up arrow to access my hidden icons and right click the Kai icon, change orbs to HQ. It will then "detach" and eventually re-connect or give you that blue dialog saying to refresh, give it a minute. After refreshing, log back in and you should see those same folks. Now head to the SOCOM II arena and verify by typing the number of people you see displayed as a number in the top right. They will confirm the number with how many they see.

    Do the numbers match?

    Fire up SOCOM II and log into the LAN and eventually, the lobby.

    Hit refresh on SOCOM II and give it a moment if you don't immediately see it beforehand.

    Now do you see a room?

    Metrics when clicked, identifies your PS2 with an icon?

    Packets in/out in the Local Area Connection status (right click on the actual computer's LAN adapter) in your "Change Adapter Settings" within Network and Sharing center?
    1234.JPG
    A lot of times people's routers STILL prevent the pass-through and even though they made changes, it still might be keeping them from seeing a room. I suspect your router to be the cause. Usually is the last thing to hurdle before the finish. Still an easy fix, but needs identification as the root first.

    It should be this fast:

    Takes 25 seconds for me.
     
    Last edited: Mar 10, 2017
  20. Phenozd

    Phenozd Green Up

    Hey guys,

    I have been trying to get my setup working on a laptop that doesn't have an ethernet port. I have a usb->ethernet adapter that I was trying to use but that doesn't seem to be working.

    1) I tried connecting the ps2 to the laptop via the adapter and connecting using wifi

    2) I tried connecting both the ps2 and the laptop to the router via ethernet.

    I can't seem to get the laptop to recognize the ps2. Any ideas?
     

Share This Page