XLINK Guide Updated for 2017

Discussion in 'SOCOM On XLink' started by Tawok, Feb 11, 2017.

  1. Swill

    Swill Killjoy

    Try "Bridging" the connection. I'm on wireless internet as well, and if I don't bridge the connection when I go to play, it won't work.

    Try that and let us know what happens.
     
  2. dizee

    dizee Lucille is thirsty

    dont think it will work w/o a built in ethernet port but i could be wrong. you can go into the xlink config and try changing the network adapter option to the USB-ethernet dongle though if it shows up there.
     
    Last edited: Mar 13, 2017
  3. MR.BLONDE

    MR.BLONDE HE STINKS AND I DON'T LIKE HIM

    I've only heard horror stories about trying to use USB-Ethernet adapters, unfortunately.
     
  4. QuizTime

    QuizTime Green Up

    can i have my laptop wireless and my ps2 hardlined into my router and make this work? i have everything setup correctly and im not seeing rooms in the lan
     
  5. dizee

    dizee Lucille is thirsty

    laptop wireless will work you connect your laptop to your ps2 via ethernet and then bridge the connections
     
  6. QuizTime

    QuizTime Green Up

    My laptop is wireless only and doesn't have an ether net port so I don't think I can bridge my ps2 through it. However my pd2 is hardwired to my router and my laptop is connected wirelessly. Xlink is showing it sees my ps2 when I look. I feel like this should totally be doable seeing as xlink can see my ps2? Maybe some sort of porting issue?
     
  7. Tawok

    Tawok Not *That* Kinda Guy

    Two things you can try if you suspect a porting issue - Set the port to '0' in XLINK Config. That'll bypass all traffic. Or go into your router settings and forward port 30000. I know @SkiMask has some sick skills to get you monitoring your packet traffic to see if you're making it out.
     
  8. QuizTime

    QuizTime Green Up

    So I bought a USB to ethernet adapter so now I'm hardwired on both my laptop and ps2 directly to my router and now all of a sudden xlink won't find my ps2 anymore when it was finding it when it was connected wirelessly...any ideas?
     
  9. ChicKeN

    ChicKeN Socomologist

    I am not sure what the difference is between people that bridge and people that don't bridge on wireless. But, I know a lot of people that don't bridge and wireless works just fine.

    How is this possible? Just a more advanced wireless card? Is it a firewall difference or anti-virus/malware? When I attempted to bridge on wireless like 3-4 years ago I couldn't get rooms to show up. I have been hardwired all the way since.
     
  10. Phenozd

    Phenozd Green Up

    Can I run Xlink on a Mac using a VM and make this work? Don't wanna set up bootcamp
     
  11. SkiMask

    SkiMask Devil's Advocate

    Pretty sure you can. I think there is more than a few who use macs. Sans Bootcamp? Not quite sure. There is a Mac thread and setup, did they only use that?
     
  12. You can just use the OSX XLink kai binary.

    http://cdn.teamxlink.co.uk/binary/XLink-Kai-7.4.30-universal.pkg.zip

    Notice if you get "unidentified developer" press command and click on the App. You need to do this in Finder not launchPad. After you do that you will need to click Open.
     
    SkiMask likes this.
  13. everythingred

    everythingred I once had fish tacos when I was drunk

    Got this to work, thanks for the guide. Went online for a bit today and it was awesome to play again.
     
  14. ChicKeN

    ChicKeN Socomologist

    @Dominator94

    Can you provide me with a Port Forwarding guide for Xlink? I got a new router and I'm having issues with seeing everyones pings on Xlink. My old Nighthawk router burnt up on me. I got the ASUS AC5300. Very good router with tons of options.

    Maybe there is a simple setting I need to disable to make it work automatically, i don't know.
     
  15. zZeRo_ToLLeRaNcE

    zZeRo_ToLLeRaNcE Green Up

    Okay so I've been trying this for a week now. I've installed and uninstalled xlink about 3 times now. I think I have everything set up right. I'm hardwired all the way. But every time I get on LAN their are no room's up. And I know people are playing. I'm so confused just because I've followed the set up step by step. Is there anyone who has thoughts about this, and if so is there a different set up guide I should follow?
     
  16. doom-loop

    doom-loop Green Up

    Trying to install Xlink Kai and two different Windows computers say it is not a program that opens for me, any ideas?
     
  17. Shimmy

    Shimmy Green Up

    Provide screenshots and possibly snaps of the error message. Makes it easier to troubleshoot with us.
     
  18. TOMBSTONE4U

    TOMBSTONE4U Ninja SEAL

    I haven't been able to get xlink back ever since doing a factory restore. Now when i try to click the download button I get this error message: AppData\Local\Temp\4yEvoL8o.exe.part could not be saved, because the source file could not be read.

    Not sure what changed but somehow I was always able to download it before the factory restore and now it won't after it.
     
  19. Harry62

    Harry62 hacker

    The xlink download seems to be broken. I have uploaded the installer for you.

    Link: https://www.mediafire.com/?hnw1rhxw3ffl1fm
     
  20. TOMBSTONE4U

    TOMBSTONE4U Ninja SEAL

    Thanks Harry, it's still not exactly right as far as I can't create shortcuts to my desktop and still have an error if I try to just run it but I was at least able to get the file on my system to where each time I try to start it I can run it through a compatibility test to get it to boot up. So even though It's not exactly right the way it used to be I can at least get on the xlink server and find the games on LAN.
     
    SkiMask likes this.

Share This Page